+1
Under review

Get incorrect url from my bot in telegram

John Lemon 9 months ago in General Discussion • updated 8 months ago 11

Hello everyone. I am doing a telegram bot. Users send an image to my bot, then bot sends to the server via api node. I set image data type to my image variable. The problem is that I get wrong url of the image and can't see what users send me. Here json that I get:

{"url":"AgADAgADqqcxG9EGoUmMYaD4FEfSV-latw0ABO2m7lTnzSiTwYsAAgI","width":2480,"height":2480,"caption":"","attribution":{"iconUrl":"","name":""}}

What's the problem? Any ideas? Thank you.

Under review

Could you please point me to the bot link at onsequel.com and I'll be able to look into?

Where I can get the bot link at onsequal?

When you log in to onsequel.com, open the episode of your bot and send me the Web URL (the url seen in the browser)

I checked and see only 5 input nodes followed by API node. Which one are you referring to? The one prior to API node?

Just look for input node before api node with this emoji :inbox_tray::inbox_tray:📷

John,


Got it. Will debug further and update you.

Did you solve it? I need to know your answer, cause I have deadlines.

Hi John,


You will need to open the API and click on "Test API request". Once done giving the values of variables, you will need to fill in the store response object. Click on "open json response" and fill in the data which you need to show as "store response object".

Hi Praveen,

It didn't help me. How it suppose to helps me? I need to send correct image url to the API, not get it in answer from the API.